ATTENTION! (by Comprehensive Google Map Plugin) – Solución

Hoy actualicé este y otros plugins, y me empezó  aparecer una alerta con el titular “ATTENTION! (by Comprehensive Google Map Plugin)”.

He aquí la solución:

Abrí el fichero head.php que se encuentra dentro de la carpeta del plugin (wp-content/plugins/comprehensive-google-map-plugin/head.php).

Buscá la línea donde aparezca lo siguiente cgmp.framework. Vas a ver que tiene una variable a continuación del string. Elimina la variable y los caracteres sobrantes. Esto hará que se cargue la versión no minificada del fichero js.

Ahora abrimos el fichero cgmp.framework.js. Acá tenemos que buscar la cadena var version = parseFloat($.fn.jquery);. Justo debajo hay lo siguiente if (version < 1.3) {.

Cambiamos el if por el siguiente if (version < 1.1) {.

Guardamos ambos ficheros y problema solucionado.

Explicación

Este error se da porque no esta previsto en el código la aparición de la versión 1.10 de jQuery, por lo que según el código, 1.3 es mayor que 1.10, ya que no cuenta el 0 final. Hay muchas otras soluciones al problema, esta es la más rápida.

Espero que te haya sido de ayuda…